{ claus.conrad }

FreeBSD

https://www.freebsd.org/

Excerpt

FreeBSD is an operating system used to power modern servers, desktops, and embedded platforms. A large community has continually developed it for more than thirty years. Its advanced networking, security, and storage features have made FreeBSD the platform of choice for many of the busiest web sites and most pervasive embedded networking and storage devices.

Resources

Notes

  • PC-BSD was a desktop operating system based on FreeBSD.
  • The popular TrueNAS storage software is based on FreeBSD.

FAQ

Recursive ACLs commands

I was just wondering if I can set or lists acls recursively on specific directories ?

I couldn’t find the usual ‘-R’ option for setfacl

Is there another way to do this?

find . -type f -exec setfacl -m xxx {} \;

or

find . -type d -exec setfacl -d -m u::,g::,o::,g:rrr:rwx {} \;

I hope you have got idea

List open Internet or UNIX domain sockets

See sockstat

Update procedure (host and jail)

Host

su -
freebsd-update fetch install
pkg update # IF THAT FAILS, FOLLOW INSTRUCTIONS HERE: https://wiki.freebsd.org/pkgng
pkg upgrade -y
pkg audit -F
portsnap fetch
portsnap update # OR IF THAT FAILS: # portsnap extract
/usr/local/sbin/portmaster -L --index-only | egrep '(ew|ort) version|total install'
/usr/local/sbin/portmaster -a --no-confirm -b -d  # OR IF THAT FAILS, run /usr/local/sbin/portmaster for each package listed in the previous commands output
ezjail-admin update -u
ezjail-admin update -P

New jails - only once

In each jail, ONCE:

rm /usr/local/etc/pkg.conf
mkdir -p /usr/local/etc/pkg/repos
nano /usr/local/etc/pkg/repos/FreeBSD.conf

Contents of above file:

FreeBSD: {
url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest",
mirror_type: "srv",
enabled: yes
}

In each jail, ONCE:

echo 'WITH_PKGNG=yes' >> /etc/make.conf
pkg update && pkg upgrade
pkg2ng
pkg upgrade
pkg install -y portmaster

Jails

In each jail:

pkg update && pkg upgrade -y && pkg audit -F
/usr/local/sbin/portmaster -L --index-only | egrep '(ew|ort) version|total install'
/usr/local/sbin/portmaster -a --no-confirm -b -d
# OR IF THAT FAILS, run /usr/local/sbin/portmaster PACKAGE_NAME for each package listed in the previous commands output
pkg audit -F

Console mode scrolling

Is there a way to scroll the screen in console mode? Something like I do in Linux with Ctrl + Page Up?

FreeBSD offers a better solution than Linux: It uses the key on the keyboard that is intended to do this.

Have a look at the ScrL (Scroll Lock) key. Have you ever asked yourself what this key will do? Try it, press it! :-)